HMI Pad Forums Old forum Support (old) S7-300 Connection

This topic contains 3 replies, has 2 voices, and was last updated by  El-Papo 8 years, 1 month ago. This post has been viewed 1095 times

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #19955

    El-Papo
    Member

      I am trying to set up a connection to my S7-300 PLC but i don’t understand if i am supposed to put in a Validation code in the iPhone app, and i have no clue about where this code is set in the PLC…

      I hope someone can help me.
      Thanks in advanced.

      #19956

      John
      Keymaster

        ScadaMobile uses MW3998 as default validation tag for S7 controllers. This is fine for S7-1200 but it fails into an out of range address on some controllers such as the S7-300. Therefore, you need to set a custom memory area for the validation tag to work on your PLC. To do so you must enter the following attribute in any row on your csv file. For example if you want to use MW200,

        validation_tag = “mw200″;

        Please use lowercase letters as shown above. You can use any MW address. This attribute tells ScadaMobile to look at MW200 for a validation code. You must set a non zero value in MW200 in your PLC, and enter the same exact hexadecimal value in the connections tab in ScadaMobile. Upon connection, SM will read the value from your PLC and will only continue with communications if both values are the same.

        I can tell that this is a common source of trouble because the default validation tag can not be used on some S7 controllers, so it forces users to set a custom one. To prevent this problem in the future we are changing the default validation tag to MW998. That way virtually all S7 controllers will communicate first time without having to set anything.

        I hope that helps. Let me know in case you need some additional info.

        #19957

        tgi_andritz
        Member

          Hi,

          We tried to connect our Ipad2 to S7-300 PLC.
          We test only the connection with one tag, with this row:
          the_value,REAL,DB100.DBD16,”validation_tag=”"mw200″”;section=”"Speed”"; label=”"C1″”; controller_slot=1;”

          We set the MW200 to hex 1234 and enter the same in the validation code in your application.

          We have error message “Socket closed by remote peer”.

          Do you have an idea?

          #19958

          tgi_andritz
          Member

            Hi again,

            My problem is solved!
            This was coming from controller slot.

            Now all is working fine

          Viewing 4 posts - 1 through 4 (of 4 total)

          You must be logged in to reply to this topic.

          Copyright © SweetWilliam, S.L 2009-2013. All rights reserved.
          Science and Technology Park of the University of Girona, Emili Grahit, 91 (NarcĂ­s Monturiol building, Office P3-B03) 17003-Girona. Phone +34972183244