HMI Pad Forums Main Forums ScadaMobile Support Use "bounds={18,24};" atribute bug?

This topic contains 6 replies, has 2 voices, and was last updated by  Grzegorz 6 years, 2 months ago. This post has been viewed 803 times

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #19562

    Grzegorz
    Participant

      Hi,

      If I use "bounds" attributes for set Temperature then numerical keyboard is open automatically and is no possible to enter decimal value, only integers are possible.

      regards

      #19563

      John
      Keymaster

        Hi, This depends on the data type not on the bounds attibute. If you are using INT for instance, then you will only be able to type numbers. However, please post the entire row so we can test it and determine whether this is indeed a bug. Thanks.

        #19564

        Grzegorz
        Participant

          Hi,

          I use REAL data value, without bounds attribute is open normal keyboard and all is OK.

          [quote]ter1a,REAL,DB29.DBD38,"access=5; page=""Zawory C.O.""; section=""Temperatura i zawory C.O."" ; write_access=5; label=""Przedpokój mały"" ; comment=""Temperatura zadana""; style:=""bezel""; color=Red ; format=""3.1""; suffix:=""°C""; bounds={18,24}; hidden=(temperatura_aktualna_zadana==0)"[/quote]

          regard

          #19565

          John
          Keymaster

            Ok, thanks. We will look at it as soon as we are able. Please keep an eye on this thread in a couple of days or so.

            #19566

            John
            Keymaster

              Hello. We have been looking at this and can not reproduce the issue. There is an identical case in the provided Formula-ONE example. I get this:

              [img]http://www.sweetwilliamsl.com/wp-content/uploads/2013/10/iOS-Simulator-Screen-shot-07.10.2013-17.19.36-e1381159611248.png[/img]

              So I can enter decimal digits. Isn't this consistent with what you get ?

              Thanks

              #19567

              Grzegorz
              Participant

                Hi,

                Look at my keyboard, for me is a comma instead of a period.

                [url=http://www.flickr.com/photos/102744175@N05/10140391966/][img]http://farm6.staticflickr.com/5535/10140391966_ab7a8d69b7.jpg[/img][/url]
                [url=http://www.flickr.com/photos/102744175@N05/10140391966/]Untitled[/url] by [url=http://www.flickr.com/people/102744175@N05/]grzegorz914[/url], on Flickr

                Thanks

                #19568

                John
                Keymaster

                  Oh, I see. This is due to the language settings.
                  I will think on what is the best way to deal with it.
                  Thanks for posting this issue.

                Viewing 7 posts - 1 through 7 (of 7 total)

                You must be logged in to reply to this topic.

                Copyright © SweetWilliam, S.L 2009-2013. All rights reserved.
                Science and Technology Park of the University of Girona, Emili Grahit, 91 (Narcís Monturiol building, Office P3-B03) 17003-Girona. Phone +34972183244